Högis Dungeon

Und jetzt erst recht!

Tweet This Plugin reparieren

Ach Mist, eines meiner Plugins – Tweet This – funktioniert seit geraumer Zeit nicht mehr und ich habe es erst jetzt gemerkt… Das Plugin lässt meine selten gewordenen geistigen Ergüsse auf Twitter los. Zumindest sollte es das. Stellt sich heraus, dass es für das Plugin seit 2011 kein Update mehr gibt, in der Zwischenzeit jedoch die Twitter REST API in der Version 1 endgültig dicht gemacht wurde. Damit bricht auch die OAuth des Plugins :mad: Aber gut, PHP-Kenntnisse aus dem Hinterkopf hervorgekramt und siehe da; es lässt sich wiederbeleben.

Einfach in der tweet-this/lib/twitteroauth.php folgende Zeile anpassen:

Und schon läuft der Laden wieder :smile:

Update: zu früh gefreut, klappt nicht, HTTP 301, Dreck. Muss ich wohl weiter suchen oder ersetzen…